porro

Advisories  /  composer  /  sabberworm

composer

sabberworm/php-css-parser

Security advisories for sabberworm/php-css-parser, newest first. 1 known, all fixed. If you’re on 8.3.1 or later, none of them affect you.

Latest version

9.5.0

Advisories

1 · 0 unfixed

Last advisory

1 Jan 2020

Safe from

8.3.1

1 advisory · newest first

CRITICAL9.8 1 Jan 2020

Code injection vulnerability in allSelectors()

PKSA-2b5y-mhcw-mt5g · CVE-2020-13756

Affected

≥ 1.0.0, < 1.0.1 ≥ 2.0.0, < 2.0.1 ≥ 3.0.0, < 3.0.1
and 10 more ≥ 4.0.0, < 4.0.1 ≥ 5.0.0, < 5.0.9 ≥ 5.1.0, < 5.1.3 ≥ 5.2.0, < 5.2.1 ≥ 6.0.0, < 6.0.2 ≥ 7.0.0, < 7.0.4 ≥ 8.0.0, < 8.0.1 ≥ 8.1.0, < 8.1.1 ≥ 8.2.0, < 8.2.1 ≥ 8.3.0, < 8.3.1

Fixed in

1.0.1 2.0.1 3.0.1
and 10 more 4.0.1 5.0.9 5.1.3 5.2.1 6.0.2 7.0.4 8.0.1 8.1.1 8.2.1 8.3.1
/advisories/composer/sabberworm/php-css-parser/feed.rss

From Packagist and the GitHub advisory database · synced hourly

Know when your sites are affected.

Porro reads composer.lock and package-lock from every site on your care plans and puts the ones that need you at the top. Updates arrive as pull requests.

Start your free trial →